Start a new topic

Weather Widget In MEC Plugin Is Not Displaying

How to resolve the issue of the Weather Widget In MEC Plugin Not Displaying?

1 Comment

If you confront the issue of “Weather Widget in MEC Plugin Is Not Displaying” first of all you require to set the Darksky API Key accurately. And aligned with it is essential to set the geographical location currently. For precise information on how to do this follow along below conversation between Webus support staff and a Modern Events Calendar user. 

Here we can see a conversation from the Modern Events Calendar’s support desk which is about Weather Widget Not Displayiong and changing the weather module from °C to °F


Hi, I had activated the weather widget, along with setting up the API key needed. The widget was displaying on events for a few days but now it has stopped showing. I check to ensure the widget is still enabled. Can you please help me troubleshoot this?


Hello, After adding Darksky API Key, you should add a location in WordPress Admin > MEC Location for the events which you want to show the weather widget in their single event. This location must have Latitude and Longitude, you can get help from this site to set them: After doing this, go to your preferred Back-End Event(s) and set the Event Location and save settings. In Front-End of the single event in which you have selected this location, the weather widget will appear. Also please double check Darksky API. Regards,


Thank you for advice, I managed it. I have another question how to you change the weather module from °C to °F?


You are welcome, After v4.4.0 we add Imperial units to weather module in addition to metric units, so please check to use the latest version you can find the convert option in this image.

Login or Signup to post a comment